Исправляем ошибку «The system is running in low-graphics mode»

/www/pages/modesco/ubuntovod

Иногда у пользователей Ubuntu появляется довольно распространённая ошибка - "The system is running in low-graphics mode". Всему виной кривая работа дисплейного менеджера LightDM. Решить данную проблему очень просто.

Для начала убедитесь установлены ли у вас все важные компоненты LightDM, в особенности основные пакеты менеджера. Все пакеты я не вспомню, но вот некоторые из них: unity-greeter, lightdm-gtk-greeter, lightdm-kde-greeter и lightdm-webkit-greeter. Каждый пакет из тех, что я перечислил, подходит только для своего окружения. К примеру для работы менеджера с Unity требуется unity-greeter.

После того, как вы убедитесь в том, что требуемый для вашей оболочки пакет установлен, откройте файл /etc/lightdm/lightdm.conf и пропишите в пункте "greeter-session" тот пакет, который вы установили:

Если вы всё сделали верно, то после перезагрузки ошибки не будет.

Также самая частая ошибка, при которой появляется данное сообщение - удаление пакета "unity-greeter", который требуется для нормальной работы LightDM. Пакет часто удаляют во время удаления оболочки Unity.

А вы знали, что замечательная компания "Светлые Окна" производит и устанавливает качественные пластиковые окна ПВХ в Москве для дома и дачи, занимается остеклением балконов и лоджий. Гарантии качества и долговечности. Подробней читайте тут, на их сайте svetokna.ru.

twitast0ry
2012-11-20 22:15:00
Подскажите, что делать, если у меня xubuntu с аналогичной ошибкой иногда появляющейся после выхода из режима глубокого сна?
Vladimir Znak
2012-11-20 23:25:00
Нужно смотреть /var/log/Xorg.0.log на предмет (EE)
Lobotomy
2013-01-21 02:18:00
У меня установлен unity-greeter и содержимое lightdm.conf совпадает с указанным, но всё равно есть эта ошибка. Появилась она после моей сборки и установки lightdm из исходников. Попытался исправить, удалив новоустановленный lightdm и установив из репозитория - не помогло.
twitast0ry
2013-01-25 23:45:00
Владимир, вот что удалось найти в файле /var/log/Xorg.1.log, когда возникла ошибка ниже: (II) Loading sub module "shadow" (II) LoadModule: "shadow" (II) Loading /usr/lib/xorg/modules/libshadow.so (II) Module shadow: vendor="X.Org Foundation" compiled for 1.7.6, module version = 1.1.0 ABI class: X.Org ANSI C Emulation, version 0.4 (==) Depth 24 pixmap format is 32 bpp (==) FBDEV(0): Backing store disabled (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument (EE) FBDEV(0): FBIOPUTCMAP: Invalid argument В логах с другими цифрами всё выглядит хорошо, ошибок нет. Подскажите, пожалуйста, как исправить проблему, если знаете?
Nataly Didenko
2015-07-20 18:35:00
Спасибо, гритер решил проблему