Установка Pepper Flash Player для Chromium с помощью репозитория

Как вы знаете, последняя доступна версия Adobe Flash Player для Linux - 11.2, обновляется она только для браузеров Chrome. Связано это с тем, что Adobe отказались от Linux, а Google взяла разработку в свои руки, попутно обозвав свою разработку Pepper.

Как-то я писал как использовать Pepper в Chromium, однако было необходимо установить браузер Google Chrome, даже если вы им не пользуетесь. Теперь вам достаточно установить один пакет из специального репозитория, который сделает практически всю работу. Он скачает стабильную версию Google Chrome, распакует Pepper Flash Player и установит только его. Chrome устанавливать не придётся.

Данный пакет представляет из себя только установщик Pepper, в нём не содержаться какие-либо файлы из Google Chrome, Adobe Flash и других программ.

Установка Pepper в Chromium

Итак, для установки Pepper Flash Player в Chromium вам нужно воспользоваться следующими командами:

sudo add-apt-repository ppa:skunk/pepper-flash
sudo apt-get update && sudo apt-get install pepflashplugin-installer

После установки вам нужно указать Chromium, что нужно пользоваться Pepper Flash Player. Для этого отредактируйте файл запуска браузера. Введите следующую команду:

sudo gedit /etc/chromium-browser/default

И в самом конце файла вставьте следующую строчку:

. /usr/lib/pepflashplugin-installer/pepflashplayer.sh

Затем сохраните и закройте файл. Всё, установка завершена.

Теперь перезапустите Chromium, перейдите на chrome://plugins и удостоверьтесь в том, что у вас стоит последняя версия Adobe Flash Player.

У вас наверняка будет установлено две версии Adobe Flash Player, одну из них (ту, которая старее) вам нужно будет отключить:

Установка Pepper Flash Player для Chromium с помощью репозитория

Чтобы отключить ненужную версию кликните по кнопке "Подробнее" в правом верхнем углу.

После всех изменений перезагрузите браузер и наслаждайтесь стабильной работой Flash-элементов.

Не знаете где купить аккумулятор samsung s5830? Тогда вам на сайт tuta.com.ua.

Олег Карыхалин
2013-05-01 11:51:00
И сильно ли отличаются версии 11.2 и 11.7?:)
Денис Попов
2013-05-01 15:43:00
У меня не заработало. Все осталось по-прежнему, Adobe Flash 11.2 в списке плагинов, Pepper не появился. Причем в инструкции ошибок нет, при добавлении репозитория пишется все то же самое, только по-английски. Ubuntu 12.04.1-64 Chromium 25.0.1364.160
paulus
2013-05-01 18:17:00
Подключаем PepperFlash в Chromium (без лишних пакетов) http://imhology.blogspot.com/2012/10/pepperflash-chromium.html
paulus
2013-05-01 18:19:00
Больше глюков, то уровень громкости не сохраняет, то не вкл. после подтверждений и т.д. 11.2 стабильнее и лучше. Единственный минус, не показывает вторую строку (подпись, кто перевел или пишут что субтитры).
paulus
2013-05-01 18:23:00
включи в chrome://plugins опцию Подробнее и увидишь
Денис Попов
2013-05-01 20:42:00
Увидел только после перезагрузки компа. Перезапуска Chromium'а недостаточно.
paulus
2013-05-01 23:04:00
Бред, достаточно обновить вкладку браузера в которой есть флеш и он уже будет с на другом проигрывателе. Хотя у меня 28.0.1496.0 (197631). Почему сидим на старье, когда даже хром 26 стабильный?
Денис Попов
2013-05-02 01:55:00
После перехода на Pepper исчез неприятный глюк при отображении графиков курсов валют и сырья на яндексе (список отображался за графиком и его не было видно). Теперь все в порядке.
Гость
2013-11-25 20:06:00
Отключать старую версию флеша не обязательно. Все равно по умолчанию будет работать более новая, а старая не особо-то мешает! Проверено, работает! :)
Алексей
2015-01-16 06:20:00
Спасибо за грамотно написанную статью! У меня все получилось без каких либо проблем. Спасибо!
AlexZ
2015-03-05 11:45:00
После всех описанных действий появляется след сообщение от Центра приложений: Ошибка загрузки дополнительных файлов данных Следующим пакетам необходима загрузка дополнительных данных после выполнения установки, но данные не могут быть получены или обработаны. pepflashplugin-installer Повторная попытка загрузки будет произведена позднее, либо вы можете попытаться загрузить пакеты снова сейчас. Для выполнения этой команды, необходимо соединение с интернетом.
gribanova64@inbox.ru
2016-04-06 13:43:40
Плагин
gribanova64@inbox.ru
2016-04-06 13:48:13
pepper-flash
Константин Пиратов
2016-10-19 16:46:02
Не удалось найти пакет pepflashplugin-installer