AMD (ATI) + Ubuntu

/www/pages/modesco/ubuntovod

На многих ресурсах говорят о недружелюбности ATI к Ubuntu, и вообще к GNU/Linux. Согласен с ними, но имея руки, выпрямленные в кузнице, можно всё-таки заставить их нормально работать. Попробуем! 

Ну первым делом нужна установленная Ubuntu. 🙂

Далее качаем последнюю версию проприетарного драйвера Ati:

wget http://www2.ati.com/drivers/linux/ati-driver-installer-11-10-x86.x86_64.run

После скачивания можно переименовать для дальнейшего удобного пользования:

mv ati-driver-installer-11-10-x86.x86_64.run ati-driver.run

Переходим непосредственно к установке. Установку лучше нужно делать в консоли. Для этого жмём Ctrl+Alt+F1, вводим свой логин-пароль. Все действия будут происходить от имени root-пользователя:

sudo su

Вводим пароль. Останавливаем Xserver:

service gdm stop

Даём права на запуск установщику:

chmod +x ati-driver.run

И запускаем его:

./ati-driver.run

Во время установки соглашаемся везде.

После установки необходимо инициализировать драйвер:

aticonfig --initial

Для двух мониторов:

aticonfig --initial=dual-head

Осталось перезагрузиться:

reboot

В Ubuntu 11.04 есть баг Unity при двух мониторах в системе, она запускается на втором. Возможное решение

sudo aticonfig --swap-monitor

Если у вас после перезагрузки выводится сообщение о невозможности загрузки модуля vesafb.so, то нужно просто переустановить пакет xserver-xorg-video-vesa:

sudo apt-get install --reinstall xserver-xorg-video-vesa

И пересобрать первичный загрузочный образ initramfs:

sudo update-initramfs -v -c -k `uname -r

Ну вот и всё 🙂

У вас автомобиль японского производства? Тогда вам нужны автозапчасти из японии, что бы не было никаких проблем с обслуживанием авто. Ведь если покупать не оригинальные запчасти, то от этого будет довольно сильно страдать весь автомобиль в целом. К тому же это опасно, ибо не оригинальные запчасти практически всегда отличаются низким качеством, а это значит, что автомобиль может выйти из строя в любой момент, в том числе и во время езды.

Гость
2011-11-15 15:42:00
Какие преимущества у данного драйвера перед открытым? С какими видеокартами он работает? Неужели, со всеми? На каких версиях Ubuntu стоит пробовать такой метод? В общем, спасибо за труд, но тема сисек не раскрыта.
2011-11-15 17:24:00
Не со всеми. Не поддерживаются старые видеокарты - но для них и так открытые драйвера - самое то. Ну... они дает прирост в 3D производительности, т.к. galium все же недостаточно хорош По идее пойдет на любой бубунте. На 11.10 - точно
2011-11-15 17:27:00
Раскрытие темы http://ompldr.org/vYmFhcw
qnub
2011-11-16 06:34:00
это стандартное руководство по установке дров, которо написано на каждом первом заборе - т.е. ценности в перепосте - 0. и если бы всё было так просто, то было бы замечательно если бы небыло так отстойно как оно есть на самом деле. и об этом не зря все говорят 1. есть такая карта HD3870x2 она не поддерживается в принципе и если раньше можно было подправить кое что в текстовом файле драйвера и пересобрать его запустив с поддержкой одного процессора из двух, то позже они стали выводить ватермарк в правом нижнем углу что железо не поддерживается - а это полный кабздец. 2. недавно я продал видеокарту из первого пункта и купил HD6670, т.к. ватермарк меня конкретно затрахал в итоге когда перешёл на 11.10 убунту, не знаю что пошло не так, но поставить одной командой дрова как в описании не вышло - после установки они не могли найти в системе файл libGL в итоге они нормально встали только после пересборки в пакеты системы (--buildpkg Ubuntu/oneiric) и установки их. так что руки в кузнице надо выпрямлять скорее создателям этих дров, а не пользователям.
Гость
2011-11-25 23:28:00
не могу установить дрова на Ati Radeon 5650 +ubunta 11.10, статья не помогла, выдает проблему описанную ниже ".... libGL ..и т.д", кто может помочь?
qnub
2011-11-25 23:52:00
можем. прочитай мой комментарий чуть ниже...
2011-11-26 12:13:00
qnub, можешь пошагово описать всю методику действий? я в линуксе новичок, и уже два дня бьюсь с установкой этих дров..был бы очень признателен..
qnub
2011-11-26 16:25:00
скачал. делаешь (подставляешь свои названия файла и дистриба): sh ./ati-driver-installer-11-6-x86.x86_64.run --buildpkg Ubuntu/natty sudo dpkg -i *.deb можешь предварительно скопировать скачанный файл в отдельный каталог, т.к. после выполнения первой команды будет создано несколько файлов.
Gavroshp
2011-11-26 17:16:00
что то ничего не получается, перестает загружаться система.. 11-6-x86 надо ставить или 11-10-x86? собирать ../natty или ../oneiric?
qnub
2011-11-26 20:01:00
ставить последнюю версию, собирать под твой дистриб, т.е. oneiric
Gavroshp
2011-11-26 20:40:00
так и делаю...не встает зараза, либо выдает ошибку на  файл libGL, либо не загружается система, скорее всего xserver....что могу не правильно сделать?
qnub
2011-11-26 21:28:00
не знаю. мне хватило этих двух действий...
Михаил Михайлин
2012-02-24 18:45:00
http://ubuntuforums.org/showthread.php?t=1857911 'sudo apt-get install fglrx-updates' in terminal. Everything works fine now. для ATI HD 6320 помогло Ubuntu 11.10